
 

 

2021 Q4 Testing Notes 
December 2021 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

Table of Contents 

Copyright .................................................................................................................... 3 

Disclaimer ................................................................................................................... 3 

Contact Us ................................................................................................................... 3 

Document History ........................................................................................................... 3 

1 Introduction ......................................................................................................................... 4 

2 Sonia Client.......................................................................................................................... 5 

  



 

 

Copyright  

Copyright © 2021, Planet Software Pty Ltd. Licensed users of Sonia are permitted to copy and reprint all or part of 

this document for the purposes of supporting their use of Sonia.  

Sonia is a registered trademark of Planet Software Pty Ltd.  

Disclaimer  

This document is provided at no charge to licensed users of Sonia. The information it contains is provided without any 

express, statutory or implied warranties. Planet Software will not be held liable for any damages caused or alleged to 

be caused either directly or indirectly by this document.   

Contact Us  

QSR International 

35 Corporate Drive 

Burlington, MA 01803 

USA 

Phone:  US: +1 617-491-1850 

 AU: +61 3 9840 4900 

Email:  help@soniasupport.com 

Web:  www.soniasupport.com 
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2021 Q4 December 2021 Jacob Reynolds 
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1 Introduction  

This document lists the various areas of the Sonia product suite that have changed in version 2021 Q4 from 2021 Q3. It 

can help you and your team focus their efforts on areas which have changed since you last conducted your testing.  

We strongly recommend performing a complete user acceptance test of the product which would take your specific 

data, configuration and environment into account that may reveal some operational stresses which functional testing 

does not. 

If you identify questions or issues as you test, please contact Sonia Support at help@soniasupport.com. Please be as 

detailed as possible in order to expedite a response or resolution, including the “internal tracking item #” indicated 

with the feature below. 

  

mailto:help@soniasupport.com
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2 Sonia Client 

The following changes were made within the Sonia Client:  

1. School options->Online->Global->Student->New ‘Show check summary’ and ‘Hide Documents page’ checkboxes. 

Under Global->Coordinator->New ‘Show student entry per placement’ checkbox. Under Show Students->Site 

research/preferences->New ‘Filter location:’ drop-down list. Under ‘Default authentication providers’ now 

renamed to ‘Default authentication provider to use when creating a new user’ and has been re-ordered. 

 

2. School options->Checks->Select a check->Edit->New ‘Settings’ tab. Some existing options from ‘Permissions’ tab 

have been moved here, as well as some new settings such as ‘Cleared value setting’ and ‘Default review date’. 

 

 

3. Student module->Select a student->Checks->The effects of ‘Cleared value setting’ will be applied in the Sonia 

Client whenever the user clears a check for the student. Cleared value setting: When the user clears the Student 

check, if the ‘Date completed’ field contains a valid date and the new ‘Cleared value setting’ of the check 

definition has a value then the ‘Value’ field will be automatically set to a date calculated as follows: ‘Date 

completed’ + number of days specified by ‘Cleared value setting’. Default review date: When a check is cleared, 

and after the above logic has been applied, if a ‘Default review date’ is specified on the check definition, and if 

this date is in the future, then the field ‘Review date’ will be automatically set to that date. 

 

4. School options->Lists->Other category->New columns: ‘Is collapsed’ and ‘Is restricted’. 

 

5. Client->Student module (though applicable anywhere custom field other tab is)->Select a student->Other-

>Custom fields can now be categorised for this page. Each category will initially appear collapsed/expanded 

depending on its new ‘Is collapsed’ attribute through School options->Lists->Other category. Category sections 

will be ordered based on the ‘Order’ attribute from the ‘Other category’ list. Custom fields that are not 

associated with any categories will appear under a generic group titled ‘Uncategorised’ at the bottom. Within 

each category, custom fields will be ordered based on the ‘Order’ attribute from custom fields metadata defined 

under School options. 

 

6. Client->Forms module->Select an existing form->Design->Select an existing form field->Type->New ‘Dynamic 

label’ form field is now available to be used. The key difference from a standard label and the new Dynamic 

label will allow the default picker button to be clicked so the user can select a Sonia field to use as the source. 

 

 

7. Client->Workflows->Select a Workflow->Design->Append action->Action: Communicate->Edit->Placement request 

placeholders->New ‘Placement documents’ placeholder. This will allow sending documents that are specific to an 

individual placement to the relevant stakeholders – Site contacts, Supervisors and Students – once a placement is 

approved. 

 

8. Client->Forms module->Details->Under ‘Create PDF on form completion and automatically add to assignee’s 

documents’->New ‘Document creation location’ drop-down list. Will allow choosing between the following 

options: Assignee (i.e the current location-this is the default option), Placement group, Placement request and 

Placement. 

 

 

9. Client->Placement group module->Select a Placement group->Communicate->Sites->Sites placeholders->New 

‘[AllActiveSiteContacts]’ placeholder. Allowing users to be able to email all currently active Site contacts. 

 

10. Client->Forms module->Select a Form->Design->Select a form field->Change type to document->New ‘Format’ 

drop-down list is now available under the ‘Values section. Allowing users to specify which type of files can be 

uploaded to the ‘Document’ field in forms. 
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11. Client->File->Administration->New ‘Addresses’ section. Will allow managing address related settings across the 

Sonia system. 

 

12. Client->File->New ‘Administration’ section is now available. This now allows multiple universities with multiple 

schools to exist on the same platform. This new section will allow the definition and configuration of the whole 

system, principally to manage one or more universities. 

 

13. Client->File->Administration->New ‘Administrators’ section is now available. This section will allow managing 

users with administrative privileges across the Sonia system (i.e for 1+ universities). At this level higher than a 

single university, we do not need to concern ourselves with Placement officers, rather this is where we manage 

administrators (system administrators and university administrators). 

 

14. Client->File->Administration->New ‘School Management’ section is now available. This now allows the moving of 

an existing school from ‘Sonia Live’ to its own dedicated university due to other schools at the same organisation 

wanting to also use Sonia. 

 

 

15. Launch Sonia Client->If one or more universities exist, when Sonia runs for the first time on an indviduals 

computer we will run them through an activation process. 

 

16. Client->Supervisor module->Select a supervisor->Checks->New ‘Actions’ column has been added to allow Check 

manager actions to be completed in the Sonia Client. #Internal Tracking Item: 10432 

 

17. Client->School options->Checks->’Managed’ column has been updated to include Supervisor Checks. Select a 

Check->Edit->Permissions->Supervsiors can now be ticked for ‘Managed’ and ‘Days automatic review’. 

 

 

2.2 University options 

1. University options->Culture->New ‘Enforce default culture’ setting added, enabling the ability to enforce the use 

of default culture rather than considering the browser requested cultures. 

 

2. University options->Client->Updated, now has ‘Authentication’ drop-down which lists names of authentication 

providers that are defined under the integrations section and marked to be active for the Client. 

 

3. University options->Online->Update to existing subsection ‘Web address and authentication’->New types of 

configurations now available: ‘Active’, ‘Passive’ and ‘Mixed’. Active being when user input is required like Sonia 

auth, Passive means that the user is sent off elsewhere to be authenticated and mixed provides the user interface 

to allow both in Sonia Online. New ‘Home page settings’, ‘Display settings’ and ‘Online limits and restrictions’ 

subsections. New text tab. 

 

4. University options->Check Manager->’Users’ information has been moved onto its own tab. ‘Authentication’ 

replaces the configuration setting that allows choosing among different authentication, the drop-down will now 

list the names of authentication providers defined under the ‘Integrations’ section and marked to be active for 

Check manager. 

 

5. University options->Dashboard->’Users’ information has been moved onto its own tab. ‘Authentication’ replaces 

the configuration settings that allows choosing different authentication, the drop-down will now list the names of 

authentication provdiers defined under the ‘Integrations’ section and marked to be active for Dashboard. 
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6. University options->New ‘Scheduled jobs’ tab. Allowing users to define when Scheduled jobs such as: 

Notifications, Workflows, Importer, geocode optimisation and External providers run. 

 

7. University options->Integrations->New ‘Email provider’ sub section. Allowing users to choose the default email 

provider, either being SendGrid or EASendMail. 

 

 

8. University options->Integrations->New ‘Authentication providers’ section. Can now add/edit and delete 

authentication providers and enable them to be active for Client, Online, Check Manager and Dashboard. 

Authentication options available are: Sonia, SAML 2, Windows Authentication and Active Directory (AD). 

 

9. University options->Integrations->Authentication providers->’Sonia Authentication’ can now be set from university 

options for Client, Online, Check Manager and Dashboard. 

 

 

10. University options->Integrations->Authentication providers->’SAML 2’ authentication can now be set from 

university options for Client, Online, Check Manager and Dashboard. 

 

11. University options->Integrations->Authentication providers->’Windows Authentication’ can now be set from 

university options for Client, Check manager and Dashboard. 

 

12. University options->Integrations->Authentication providers->’Active Directory (AD)’ authentication can now be set 

from university options for Online. 

 

13. University options->Checks/Custom fields->New functionality now added: Re-ordering has been enhanced. Rather 

than just display the order number, will allow incline editing of that number so that a check/custom field can 

quickly be moved to that row, and all others beneath get shuffled down. 

 

 

14. University options->Schools->Add->Under Check Manager and Dashboard sections->Can now define the URL’s for 

both applications at a school level. 

 

15. University options->New ‘Importer’ section, existing School mappings and Region mappings sections have been 

moved under this new section. This new ‘Importer’ section will allow system and university administrators to 

manage all configuration settings used by the Student Importer, as well as provide monitoring tools. 

 

 

16. University options->Scheduled jobs->New ‘Importer’ section has now been added. Which will allow system and 

university administrators to schedule its execution as needed. 

 

3 Sonia Online 

1. Client->Student module->Select a student->Impersonate->My details->Scroll down to Custom fields->Like in the 

Client, will now display categorised Custom fields. Restricted categories and/or their related custom fields will 

not be displayed in Sonia Online, just Client. 
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2. Client->Forms module->Select an existing Form->Design->Select a form field->Type->Dynamic label. Dynamic 

label will now appear in Online forms, the visual output will be the default value, if the user does not need 

anything displayed before the value, they can simply enter a blank space in description of the form field at 

design time, and this will effectively show just the default value. 

 

4 Sonia Reports 

1. Client->Reports->Select either Student/Supervisor report sections->Find and select a report with the Custom field 

symbol->Edit->New ‘Custom fields’ section is now available. Using this new section, users are able to perform 

custom field mapping for reports. 

 

5 Sonia Check Manager 

1. Launch Check Manager->Login->New ‘Supervisor’ menu option is now available. This will enable the Check 

Manager user to access functionality to search and view and complete supervisor checks (as per the equivalent 

Students menu). 

 

2. Launch Check Manager->Login->Admin->User Checks->Select a School->New ‘Student’ and ‘Supervisor’ columns 

have now been added. Allowing Check manager users to see whether a check is for a student or for a Supervisor. 

 

 

3. Launch Check Manager->Login->Admin->Notifications->Add/edit->New ‘Students’ and ‘Supervisors’ columns now 

available. Allowing using to see which notifications are associated with which checks and role. 

 

4. Launch Check Manager->Login->Checks->Search->Will now display both Students and Supervisor checks. This 

checks list can be filtered to a particular role as needed. 

 

 

5. Launch Check Manager->Login->Admin->Manage users->Add/edit->Now when add/editing a Check manager user, 

administrators will be able to define whether they can view student and/or supervisor checks. ‘Can view student 

checks’ is ticked by default when creating new users. 

 

6. Launch Check manager->Login->New ‘Supervisors’ search functionality is now available. Allowing check manager 

users to Search for Supervisors like with Students. This page also allows bulk emailing and exporting like with 

Student search module. 

 

 

7. Launch Check Manager->Login->Overview page->New ‘Supervisors’ tab is now available. The Supervisor’s tab is 

identical to the students one, except showing Supervisor Checks. Checks tab will now include Students & 

Supervisors if the user has permission to see both. 

 

8. Launch Check Manager->Login->Student->Search->Search->Edit a student check->’Apply cleared checks’ 

functionality has now been introduced into the Sonia Check manager. 

 

9. Launch Check Manager->Login->Admin->Notifications->Edit a Notification->Select new ‘quick parts’ icon, allowing 

users to be able to save sections of their email to be used again through the ‘AutoText’ section.  

 


